Не работают 2 плагина | Minecraft

Тема в разделе "Mineсraft", создана пользователем Pooolg, 15 июл 2018.

  1. Pooolg

    Pooolg Новичок

    • Пользователь
    Не работают: worldedit, и worldguard - вылетают с ошибкой:

    Код:
    [00:03:49 ERROR]: Could not load 'plugins/worldedit-6.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:164) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_162]
    Caused by: org.yaml.snakeyaml.error.YAMLException: java.util.zip.ZipException: invalid LOC header (bad signature)
        at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:200) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:381) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:232) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:159) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        ... 5 more
    Caused by: java.util.zip.ZipException: invalid LOC header (bad signature)
        at java.util.zip.ZipFile.read(Native Method) ~[?:1.8.0_162]
        at java.util.zip.ZipFile.access$1400(ZipFile.java:60) ~[?:1.8.0_162]
        at java.util.zip.ZipFile$ZipFileInputStream.read(ZipFile.java:734) ~[?:1.8.0_162]
        at java.util.zip.ZipFile$ZipFileInflaterInputStream.fill(ZipFile.java:434) ~[?:1.8.0_162]
        at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:158) ~[?:1.8.0_162]
        at java.io.FilterInputStream.read(FilterInputStream.java:133) ~[?:1.8.0_162]
        at java.io.PushbackInputStream.read(PushbackInputStream.java:186) ~[?:1.8.0_162]
        at org.yaml.snakeyaml.reader.UnicodeReader.init(UnicodeReader.java:90) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:122) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at java.io.Reader.read(Reader.java:140) ~[?:1.8.0_162]
        at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:184) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:381) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.PluginDescriptionFile.<init>(PluginDescriptionFile.java:232) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:159) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        ... 5 more
    [00:03:49 INFO]: Set PluginClassLoader as parallel capable
    [00:03:49 ERROR]: Could not load 'plugins/worldguard-6.1_v.0.7_new.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/Injector
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_162]
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/Injector
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_162]
        at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_162]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        ... 6 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.Injector
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_162]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_162]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_162]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_162]
        at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_162]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[Spigot.jar:git-Spigot-e4d4710-e1ebe52]
        ... 6 more
    Ядро свое, на других хостингах вся моя сборка работает, как и на локальном ПК,
    единственное что заметил, это то, что не могу загрузить по ftp и через менеджер
    папку "tmp", а в ней у меня 2 файла "libnetty-transport-native-epoll8304284741116080445.so", и
    "sqlite-3.7.2-libsqlitejdbc.so" + папка "hsperfdata_gs-40264" с содержимым "1".

    Прошу помочь, ибо без регионов мне не как.
    Покупал тариф PRO 4ГБ
    --- Сообщения объединены, 16 июл 2018, предыдущее сообщение: 15 июл 2018 ---
    Все решено в дискорд
     
  2. Howarddah

    Howarddah Новичок

    • Пользователь
    Xembongdahd
     
  3. CarsenSn

    CarsenSn Новичок

    • Пользователь

Поделиться этой страницей